安装vbox增强包

2012-12-12 13:37

     这几天在虚拟机上安装了几个不同版本的linux,有bt5,Fedora17和opensuse12.3,安装过程都比较顺利,只是安装增强包的时候,遇到了一点麻烦。记录一下。

     fedora17:

        yum install gcc make gcc-c++

        yum install kernel-devel kernel-headers

       安装成功后,再安装vbox增强包,结果编译总是不能成功。把所有的软件包都更新一遍,还是不行。搜索了一圈,也没发现哪个步骤不对。仔细看了一下编译时出错的提示,感觉可能是因为内核版本的问题,下载安装了最新版本的virtualbox4.2.4,然后再安装增强包,果然正常编译了。

    opensuse12.3:

      zypper install  gcc make

     zypper kernel-source 

     这两步都会根据依赖关系,自动安装其他的包。

     再安装vbox增强包,编译成功了。 

     对于虚拟机usb不能使用的问题,需要把当前用户增加到vboxusers组里面,sudo usemod -a -G vboxusers gaoyu,注销,重新启动gnome,这样就可以了。

点击微信扫一扫

最近留言

没有数据
扫描二维码访问
欢迎使用手机扫描二维码访问